News‎ > ‎

EndNote X9.3.1 is required for compatibility with Catalina Mac OS

posted Nov 12, 2019, 1:45 PM by Ken Gribble
Endnote users! Be aware, EndNote X9.3.1 is required for compatibility with Catalina!

https://support.clarivate.com/Endnote/s/article/EndNote-for-Mac-macOS-Catalina-Compatibility?language=en_US
Comments